首页 >  PHP频道 > PHP相关 > 

"Ghost" 漏洞出现,影响主流 Linux 分支

"Ghost" 漏洞出现,影响主流 Linux 分支

作者:yjl 来源:华育国际 时间:2015-02-27 访问次数:1607
"Ghost" 漏洞出现,影响主流 Linux 分支、WordPress 和 PHP 应用

又一个波及范围极广的严重漏洞出现了,它的名称叫做 "Ghost"。它允许攻击者在大多数 Linux 分支中通过邮箱服务和网页的服务器执行恶意代码。

这个漏洞来自 GNU C Library (glibc) ,在某种意义上严重程度与 Heartbleed 和 Shellshock 相当。事实上,这个漏洞两年前就被发现,但至今大多数 Linux 版本都保持在未修复的状态。另外,安装修复补丁要求系统的核心功能或受波及的整台服务器重启,这会留给攻击者更长时间的机会。

在此之前,来自 Qualys 的安全研究者已经针对该漏洞写出了攻击实例(proof-of-concept,POC)。实例中,攻击者成功绕过了现行所有的保护措施,在 32 位和 64 位环境下成功远程在 Exim 邮件服务器上执行恶意代码。

目前为止,这个漏洞已经在 RHEL 5 和 Ubuntu 12.04 中被修复,Debian、CentOS、Fedora 5/6/7 依然受到威胁。

随后,来自 Sucuri 安全机构的研究院声称:Ghost 漏洞同样还会影响 PHP 应用程序和 WordPress。攻击者可以通过这个漏洞在上述两个环境内远程进行服务器提权。