首页 >  PHP频道 > PHP相关 > 

GHOST 漏洞可能影响 WordPress 和 PHP 应用

GHOST 漏洞可能影响 WordPress 和 PHP 应用

作者:yjl 来源:华育国际 时间:2015-02-27 访问次数:1522
上周Glibc中发现了一个被取名为GHOST可被远程利用的堆缓冲区溢出漏洞,漏洞其实已被上游修复,但由于被视为bug而导致部分下游发行版没有打上补丁,受影响的发行版包括了Centos/RHEL 5、6和7,以及Ubuntu 12.04等。现在,安全研究人员认为PHP应用也可能会受

上周Glibc中发现了一个被取名为GHOST可被远程利用的堆缓冲区溢出漏洞,漏洞其实已被上游修复,但由于被视为bug而导致部分下游发行版没有打上补丁,受影响的发行版包括了Centos/RHEL 5、6和7,以及Ubuntu 12.04等。现在,安全研究人员认为PHP应用也可能会受到该漏洞的影响。 GHOST漏洞与gethostbyname()和gethostbyname2()的调用有关,研究人员认为,攻击者也可能通过PHP应用如 WordPress的gethostbyname()包装器,嵌入恶意URL去触发服务器端的堆缓冲区溢出,可能允许攻击者获得访问服务器的权限。